const regex = /(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\w*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\\w*', 'g')
const str = `Hello Mr. Brown how are you today? Good, my name is Ms. Smith ok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}