using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\w*";
string input = @"Hello Mr. Brown how are you today? Good, my name is Ms. Smith ok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}