re = /(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\w*/
str = 'Hello Mr. Brown how are you today? Good, my name is Ms. Smith ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end