import re
regex = re.compile(r"(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\w*")
test_str = "Hello Mr. Brown how are you today? Good, my name is Ms. Smith ok"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")