import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_REQUEST\\[.*\\]|\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_POST\\[.*\\]|\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_REQUET\\[.*\\]";
final String string = "afrawefaew = $_REQUEST['foo']\n"
+ "sfvdfvsdfv=$_REQUEST['foo']\n"
+ "sdfvsdfv =$_REQUEST['barbar']\n"
+ "sdfvsdfv= $_REQUEST['baz']\n"
+ "sdfsdv == $_REQUEST['123sgrtrthrsh']\n\n"
+ "$_GET['foo']\n"
+ "$_GET['barbar']\n"
+ "$_get['baz']\n"
+ "$_POST['123sgrtrthrsh']\n"
+ "$_post['123sgrtrthrsh']\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}