import Foundation
let pattern = #"\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
afrawefaew = $_REQUEST['foo']
sfvdfvsdfv=$_REQUEST['foo']
sdfvsdfv =$_REQUEST['barbar']
sdfvsdfv= $_REQUEST['baz']
sdfsdv == $_REQUEST['123sgrtrthrsh']
$_GET['foo']
$_GET['barbar']
$_get['baz']
$_POST['123sgrtrthrsh']
$_post['123sgrtrthrsh']
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)