import re
regex = re.compile(r"\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]", flags=re.IGNORECASE)
test_str = ("afrawefaew = $_REQUEST['foo']\n"
"sfvdfvsdfv=$_REQUEST['foo']\n"
"sdfvsdfv =$_REQUEST['barbar']\n"
"sdfvsdfv= $_REQUEST['baz']\n"
"sdfsdv == $_REQUEST['123sgrtrthrsh']\n\n"
"$_GET['foo']\n"
"$_GET['barbar']\n"
"$_get['baz']\n"
"$_POST['123sgrtrthrsh']\n"
"$_post['123sgrtrthrsh']\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")