# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\s>])(?!(?:[^<>]*)?>)/<span>$1<\/span>/gu;t' <<< "<br/>Hi <br/> there."