import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"([^\s>])(?!(?:[^<>]*)?>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<br/>Hi <br/> there."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)