$re = '/([^\s>])(?!(?:[^<>]*)?>)/u';
$str = '<br/>Hi <br/> there.';
$subst = "<span>$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;