use strict;
my $str = '<br/>Hi <br/> there.';
my $regex = qr/([^\s>])(?!(?:[^<>]*)?>)/up;
my $subst = '<span>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";