#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^10\.\d+\.\d+\.\d+$"
Local $sString = "10.999.0.0" & @CRLF & _
"10.254.0.1" & @CRLF & _
"10.0.10.0" & @CRLF & _
"10.0.10.1" & @CRLF & _
"10.10.10.0" & @CRLF & _
"10.10.10.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")