import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^10\\.\\d+\\.\\d+\\.\\d+$";
final String string = "10.999.0.0\n"
+ "10.254.0.1\n"
+ "10.0.10.0\n"
+ "10.0.10.1\n"
+ "10.10.10.0\n"
+ "10.10.10.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}