re = /^10\.\d+\.\d+\.\d+$/m
str = '10.999.0.0
10.254.0.1
10.0.10.0
10.0.10.1
10.10.10.0
10.10.10.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end