$re = '/^10\.\d+\.\d+\.\d+$/m';
$str = '10.999.0.0
10.254.0.1
10.0.10.0
10.0.10.1
10.10.10.0
10.10.10.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);