const regex = /^10\.\d+\.\d+\.\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^10\\.\\d+\\.\\d+\\.\\d+$', 'gm')
const str = `10.999.0.0
10.254.0.1
10.0.10.0
10.0.10.1
10.10.10.0
10.10.10.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}