#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+[\/,-]){2,}\d+$"
Local $sString = "22" & @CRLF & _
"23" & @CRLF & _
"23,23,23-" & @CRLF & _
",23,23,23" & @CRLF & _
"23,23,23," & @CRLF & _
"23--23" & @CRLF & _
"23-23" & @CRLF & _
"23,,23" & @CRLF & _
"23,23,23" & @CRLF & _
"233-2-3,23,23" & @CRLF & _
"23/23/2333,22-22-2222,23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")