using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+[\/,-]){2,}\d+$";
string input = @"22
23
23,23,23-
,23,23,23
23,23,23,
23--23
23-23
23,,23
23,23,23
233-2-3,23,23
23/23/2333,22-22-2222,23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}