// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+[\/,-]){2,}\d+$").unwrap();
let string = "22
23
23,23,23-
,23,23,23
23,23,23,
23--23
23-23
23,,23
23,23,23
233-2-3,23,23
23/23/2333,22-22-2222,23";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}