import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+[\\/,-]){2,}\\d+$";
final String string = "22\n"
+ "23\n"
+ "23,23,23-\n"
+ ",23,23,23\n"
+ "23,23,23,\n"
+ "23--23\n"
+ "23-23\n"
+ "23,,23\n"
+ "23,23,23\n"
+ "233-2-3,23,23\n"
+ "23/23/2333,22-22-2222,23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}