package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+[\/,-]){2,}\d+$`)
var str = `22
23
23,23,23-
,23,23,23
23,23,23,
23--23
23-23
23,,23
23,23,23
233-2-3,23,23
23/23/2333,22-22-2222,23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}