#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)^[a-z0-9\-'\s\p{Arabic}]{1,}$"
Local $sString = "تكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساس"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")