package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z0-9\-'\s\p{Arabic}]{1,}$`)
var str = `تكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساس`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}