using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9\-'\s\p{Arabic}]{1,}$";
string input = @"تكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساس";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}