import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9\\-'\\s\\p{Arabic}]{1,}$";
final String string = "تكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساس";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}