$re = '~^[a-z0-9\-\'\s\p{Arabic}]{1,}$~iu';
$str = 'تكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساستكساستكساستكساستكساستكساس تكساس';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);