#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:\s*<\s*(?!bar)\w+\s*>\s*)*(<\s*bar\s*>)){2}"
Local $sString = "< foo >< bar >< baz >" & @CRLF & _
"< foo >< bar >< baz >" & @CRLF & _
"< foo >< bar >< baz >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")