const regex = /(?:(?:\s*<\s*(?!bar)\w+\s*>\s*)*(<\s*bar\s*>)){2}/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\s*<\\s*(?!bar)\\w+\\s*>\\s*)*(<\\s*bar\\s*>)){2}', 'm')
const str = `< foo >< bar >< baz >
< foo >< bar >< baz >
< foo >< bar >< baz >`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}