$re = '/(?:(?:\s*<\s*(?!bar)\w+\s*>\s*)*(<\s*bar\s*>)){2}/m';
$str = '< foo >< bar >< baz >
< foo >< bar >< baz >
< foo >< bar >< baz >';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);