import Foundation
let pattern = #"(?:(?:\s*<\s*(?!bar)\w+\s*>\s*)*(<\s*bar\s*>)){2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
< foo >< bar >< baz >
< foo >< bar >< baz >
< foo >< bar >< baz >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}