import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\s*<\\s*(?!bar)\\w+\\s*>\\s*)*(<\\s*bar\\s*>)){2}";
final String string = "< foo >< bar >< baz >\n"
+ "< foo >< bar >< baz >\n"
+ "< foo >< bar >< baz >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}