using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\h*\[if.*\]\R # if in the first line
(?<if>(?:(?!\[elseif)[\s\S])+)\R # output
^\h*\[elseif.*\]\R # elseif
(?<elseif>(?:(?!\[else)[\s\S])+)\R # output
^\h*\[else.*\]\R # elseif
(?<else>(?:(?!\[endif)[\s\S])+)\R # output
^\[endif\]
";
string input = @"[if:(a+b-c/d*e)|(x-y)&!(z%3=0)]
output
[elseif:('b'+'atman'='batman')]
output2
out as well
[else]
output3
some other output here
[endif]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}