re = /^\h*\[if.*\]\R # if in the first line
(?<if>(?:(?!\[elseif)[\s\S])+)\R # output
^\h*\[elseif.*\]\R # elseif
(?<elseif>(?:(?!\[else)[\s\S])+)\R # output
^\h*\[else.*\]\R # elseif
(?<else>(?:(?!\[endif)[\s\S])+)\R # output
^\[endif\]
/mx
str = '[if:(a+b-c/d*e)|(x-y)&!(z%3=0)]
output
[elseif:(\'b\'+\'atman\'=\'batman\')]
output2
out as well
[else]
output3
some other output here
[endif]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end