import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*\\[if.*\\]\\R # if in the first line\n"
+ "(?<if>(?:(?!\\[elseif)[\\s\\S])+)\\R # output\n"
+ "^\\h*\\[elseif.*\\]\\R # elseif\n"
+ "(?<elseif>(?:(?!\\[else)[\\s\\S])+)\\R # output\n"
+ "^\\h*\\[else.*\\]\\R # elseif\n"
+ "(?<else>(?:(?!\\[endif)[\\s\\S])+)\\R # output\n"
+ "^\\[endif\\]\n\n\n";
final String string = "[if:(a+b-c/d*e)|(x-y)&!(z%3=0)]\n"
+ "output\n"
+ "[elseif:('b'+'atman'='batman')]\n"
+ "output2\n"
+ "out as well\n"
+ "[else]\n"
+ "output3\n"
+ "some other output here\n"
+ "[endif]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}