import re
regex = re.compile(r"""
^\h*\[if.*\]\R # if in the first line
(?<if>(?:(?!\[elseif)[\s\S])+)\R # output
^\h*\[elseif.*\]\R # elseif
(?<elseif>(?:(?!\[else)[\s\S])+)\R # output
^\h*\[else.*\]\R # elseif
(?<else>(?:(?!\[endif)[\s\S])+)\R # output
^\[endif\]
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("[if:(a+b-c/d*e)|(x-y)&!(z%3=0)]\n"
"output\n"
"[elseif:('b'+'atman'='batman')]\n"
"output2\n"
"out as well\n"
"[else]\n"
"output3\n"
"some other output here\n"
"[endif]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")