const regex = new RegExp('^\\h*\\[if.*\\]\\R # if in the first line
(?<if>(?:(?!\\[elseif)[\\s\\S])+)\\R # output
^\\h*\\[elseif.*\\]\\R # elseif
(?<elseif>(?:(?!\\[else)[\\s\\S])+)\\R # output
^\\h*\\[else.*\\]\\R # elseif
(?<else>(?:(?!\\[endif)[\\s\\S])+)\\R # output
^\\[endif\\]
', 'gm')
const str = `[if:(a+b-c/d*e)|(x-y)&!(z%3=0)]
output
[elseif:('b'+'atman'='batman')]
output2
out as well
[else]
output3
some other output here
[endif]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}