#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:, \d+)*$"
Local $sString = "1" & @CRLF & _
"2, 3" & @CRLF & _
"6, 7, 4" & @CRLF & _
",5" & @CRLF & _
"5 6 0" & @CRLF & _
"4,5" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1 - ok!" & @CRLF & _
"2, 3 - ok!" & @CRLF & _
"6, 7, 4 -ok!" & @CRLF & _
",5 - bad!" & @CRLF & _
"5 6 0 - bad!" & @CRLF & _
"4,5 - bad!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")