$re = '/^\d+(?:, \d+)*$/m';
$str = '1
2, 3
6, 7, 4
,5
5 6 0
4,5
1 - ok!
2, 3 - ok!
6, 7, 4 -ok!
,5 - bad!
5 6 0 - bad!
4,5 - bad!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);