const regex = /^\d+(?:, \d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:, \\d+)*$', 'gm')
const str = `1
2, 3
6, 7, 4
,5
5 6 0
4,5
1 - ok!
2, 3 - ok!
6, 7, 4 -ok!
,5 - bad!
5 6 0 - bad!
4,5 - bad!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}