import re
regex = re.compile(r"^\d+(?:, \d+)*$", flags=re.MULTILINE)
test_str = ("1\n"
"2, 3\n"
"6, 7, 4\n"
",5\n"
"5 6 0\n"
"4,5\n\n\n"
"1 - ok!\n"
"2, 3 - ok!\n"
"6, 7, 4 -ok!\n"
",5 - bad!\n"
"5 6 0 - bad!\n"
"4,5 - bad!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")