using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:class).*(?<!\-)(?:[[:blank:]]|\"")(button)(?:[[:blank:]]|\"")";
string input = @"class=""button""
class="" button""
class="" my-button""
class=""mybutton""
class="" my button""
class="" my buttong""
""button""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}