import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:class).*(?<!\\-)(?:[[:blank:]]|\\\")(button)(?:[[:blank:]]|\\\")";
final String string = "class=\"button\"\n"
+ "class=\" button\"\n"
+ "class=\" my-button\"\n"
+ "class=\"mybutton\"\n"
+ "class=\" my button\"\n"
+ "class=\" my buttong\"\n"
+ "\"button\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}