$re = '/(?:class).*(?<!\-)(?:[[:blank:]]|\")(button)(?:[[:blank:]]|\")/';
$str = 'class="button"
class=" button"
class=" my-button"
class="mybutton"
class=" my button"
class=" my buttong"
"button"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);