const regex = /(<img.*\/>)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img.*\\\/>)', 'i')
const str = `http://www.google.com <img src="http://placehold.it/350x150" />`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);