const regex = /h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d', '')
const str = `1h2e3l4l5o6 7w8o9r0l0d0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}