import Foundation
let pattern = #"h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1h2e3l4l5o6 7w8o9r0l0d0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}