$re = '/h.*e.*l.*l.*o.* .*w.*o.*r.*l.*d/';
$str = '1h2e3l4l5o6 7w8o9r0l0d0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);