use strict;
my $str = '381651651.7148949841%';
my $regex = qr/(\d+)\D(\d+)\D/mp;
my $subst = '$1,$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";