import Foundation
let pattern = #"(\d+)\D(\d+)\D"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"381651651.7148949841%"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)