$re = '/(\d+)\D(\d+)\D/m';
$str = '381651651.7148949841%';
$subst = "$1,$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;